Mobile data not working on Nexus 5

November 8, 2013 1:38 pm Published by 4 Comments

I just purchased a new Nexus 5 and was having some trouble getting my mobile data connection to work. Here’s how to fix it. (Note: these APN settings may be specific to Virgin Mobile Australia.)

After trying several different APN’s I finally decided to delete some of the other default access points which were obviously incorrect (e.g. Optus Business Broadband etc.). Finally once I had deleted all the other access points, including the MMS settings and had only one APN left (named virgininternet) mobile data began to work!

Simply delete all other APN’s – including MMS settings and leave the virgininternet APN

Here’s a screenshot of my APN settings:

Virgin Mobile APN settings for Nexus 5

Categorised in:

This post was written by WillyNilly

4 Comments

  • Graeme says:

    You’re awesome I just had the same problem and was starting to freak out. Thanks mate!

  • RJ says:

    mate thanks very much for this now its 100% working I was clueless off what was happening. But this fixed everything

  • Zac says:

    Thank you so much! I looked everywhere. I reset my phone twice, played around with all the APN settings and this worked perfectly.

    Thanks again, I really appreciate it.

  • David says:

    Hi, thank you so much! I had no explanation why mobile data on a number of prepaid sims here in Spain wasn’t working. After using your method it started working immediately! Our vacation is saved ;)!!!

Leave a Reply

Your email address will not be published. Required fields are marked *